Kawasaki Z1000 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I've got a ticking noise coming from under the seat of a brand new 2010 Z1000 but only after I installed a Power Commander V today. And to top it off, there is no map as of right now if anybody is running a full Akrapovic exhaust- just so you guys know. Any help with the ticking guys? Sounds like it might be a relay or something... Thanks for looking

:eek:ccasion:
SSgt Garland Keaton
UNITED STATES AIR FORCE
CHARLESTON SC
 

·
Registered
Joined
·
42 Posts
Did you put in the full exhaust? I'm guessing so. You took off the seat and didn't see anything mechanically causing the noise? I would GUESS it's something with the exhaust servo? The servo is under the seat. It has/had the cables running through it that lead to the butterfly valve...where is the valve? Not sure. Somewhere in the stock collectors. You must have removed it during a full exhaust install since youre aftermarkets won't have a butterfly valve (I'm sure they wouldn't anyway). Maybe it's getting jammed on something?
 

·
Registered
Joined
·
1,089 Posts
How often do you hear it?
Is it constant tick.tick.tick?Fast and frequent?
Is it every once in a while,or every time?
Does it happen key on engine not running?
Need to be much more spicific,like an electrical sound or a mechanical sound.
Does it change at different rpm?
Let me know everything.ive been a bike mechanic for 20 plus years.
Details are everything when trying to diagnose a bike without actually having the bike available....trying to help....Barry
 

·
Registered
Joined
·
875 Posts
how did you get a PCv without any map. mine came with a map set for muzzy. no ticking ever on my bike. left cables on the exhaust when i removed it.:screwy::screwy::screwy:
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 · (Edited)
Did you put in the full exhaust? I'm guessing so. You took off the seat and didn't see anything mechanically causing the noise? I would GUESS it's something with the exhaust servo? The servo is under the seat. It has/had the cables running through it that lead to the butterfly valve...where is the valve? Not sure. Somewhere in the stock collectors. You must have removed it during a full exhaust install since youre aftermarkets won't have a butterfly valve (I'm sure they wouldn't anyway). Maybe it's getting jammed on something?
Looked at the servo- it spins freely without any interference- Thanks for the help :cheers

How often do you hear it?
Is it constant tick.tick.tick?Fast and frequent?
Is it every once in a while,or every time?
Does it happen key on engine not running?
Need to be much more spicific,like an electrical sound or a mechanical sound.
Does it change at different rpm?
Let me know everything.ive been a bike mechanic for 20 plus years.
Details are everything when trying to diagnose a bike without actually having the bike available....trying to help....Barry
I dont hear it anymore...lol! its my FLASHER relay ticking- I know this because I tried to use my flashers last night- i got NADA! Now i gotta trouble-shoot this problem... the fuse is still good. Just dont know why after installing the PCV, it would have something to do with the flashers???

how did you get a PCv without any map. mine came with a map set for muzzy. no ticking ever on my bike. left cables on the exhaust when i removed it.:screwy::screwy::screwy:
I don't know. When I bought the bike 1 March, I immediately ordered a full Akra exhaust since that was the only full system offered that I liked. Installed the exhaust, running lean- ordered the PCV. PCV came in yesterday, installed it- went to load a map for a full system- doesn't have one for the Akrapovic. There's only 4 maps which are for the bike stock, Two-Bros slips, Akra-slips, & one other one. Do you think Akrapovic can send me a map? I know when I installed my Brock on my Busa- Brock had to send me a map...
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
Found out it was the relay that went bad. Opened up the relay & a piece had broke off the contact. Went to the stealership & they said to order another relay was $67. I went to Advance Auto Parts and found one for $6. Hope this helps someone in the future
 

·
Registered
Joined
·
42 Posts
After installing my tuner X integrated rear tail light I hear, probably, the same thing you're hearing...only I can't really hear it at all with the bike running. I chalked it up to the relay handling more power? And since I didn't check signal operation with OE rear light with the bike off, I assumed it was normal. All operates fine either way. And your PCV would have nothing to do with that relay, so I'm guessing it's a total coincidence...

Hopefully my flashers won't give out...
 

·
Registered
Joined
·
875 Posts
my caneed muzzy map was so rich i lost power. tuner steadily took away fuel til the hp jumped 10 hp. was hoping for more. pm me your email address and i'll try to send my new tuned map.:screwy::screwy::screwy:
 
1 - 9 of 9 Posts
Top