Kawasaki Z1000 Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
Guys, I need help please. Recently my bike has been bucking and maybe misfiring when going around 80mph and after riding a long time. Sometimes it doesn't happen for a week, sometimes it happens within 30 miles. I've replace fuel line, fuel pump, valve cover gasket, ran seafoam through tank. I've had a bad fuel pump before but the kicking from that was way worse then this. That's why i replaced it. And with my bad fuel pump I couldn't get past 20 mph. This new problem allows me to get up to 80 and when I turn the bike off and back on it goes away for a long time. Anyone got any ideas?? Coils? Plugs? Ground wire somewhere? I don't think its a fuel delivery issue because FI light is not on and like I said I got new fuel pump and fuel line. Also it doesn't stall when it does this so I don't think its the ECU. I've heard of the same issue but with stalling. My bike doesn't do that. Its got 20,000 miles and runs great when it's not doing this. Help PLEASE!!!
 

· Registered
Joined
·
53 Posts
Have you pulled the injectors out and tried a spray test on them? They’re pretty easy to get to and might help narrow it down. There’s always a possibility there’s a loose connection in the plug wires or something too. I wouldn’t throw too many more parts at it til I fiddled with everything I could for free. I’d take the airbox off pull the plugs see what they tell you, you can check the connections and put a multimeter on the plug wires make sure they’re not broken, pull the injectors because they’re right there once you’re that far, spray them backwards and just once over everything under there, you might find something partly unplugged or bare wires that might be crossing. Put it back together and see what you get. Maybe check the resistance on the reg/rec too. Mine went out years back on my gen 3 and the bike was acting funny for a while it’s because it would charge the battery with as much as 17 volts and it was cooking it causing al couple of weird stalls and stutters that just didn’t fit with conventional wisdom. Good luck dude
 
1 - 4 of 4 Posts
Top