Kawasaki Z1000 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
2003 z1000 i replaced all the seals and it still leaks oil from the weep hole behind the water pump, i did this 3 times already and i am very mechanically inclined but this has me stumped, i even replaced the shaft that runs the water and oil pump and the thing still leaks, it leaks when you give it throttle, it doesnt leak at idle

pleas help before i push this bike over a cliff
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Yes I replaced all the seals and the shaft, I even bought a used housing of eBay and put all new seals in that one, when the bike is at idle it doesn't leak, as soon as you give it throttle it leaks.

Could it possibly be the pressure relief valve? Stuck in the closed position? I work on all my own bikes and this one has me stumped
 

·
Registered
Joined
·
1,224 Posts
So as I understand this You replaced the Ceramic/Carbon water seal and the oil seal behind it and the o ring to block. You did put the rubber/spring tension oil seal facing correctly with the spring side facing the engine? Which is where the oil has to be coming from. So the bike had this same problem before you started working on it? Take an oil pressure reading from the right side of bike below the crankshaft sensor cover. It should be from 37 to 46 psi at 4000 rpm oil temp at around 194 degrees (warned to running temp). The relief valve isn't hard to get to but you will need to drop the pan to get to it. It is right ahead of the oil pickup very easy to get to. Hope this is of some help. Let us know how things progress. Great Day All!
 

·
Registered
Joined
·
1,175 Posts
If it is excessive pressure, something is building that pressure. Being that you've had water pump issues, did the bike ever get to a point where it overheated?

I fit did, I could picture a head gasket issue. This would allow excess pressure, in the cooling system. It finally has enough, and relieves pressure in the weakest point..that new seal.


It would be interesting to check compression in all four cylinders. The one with a bad head gasket will leak away quicker than the others...and who knows, if the radiator was empty, maybe you could hear the leak? My 1998 dodge Neon taught me this. POS car did this with 43,000 miles... It was stolen. It was one of the best moment sin my life...

Or, if its full, you might be able to see bubbling?

Please let us know what you find.
 

·
Registered
Joined
·
408 Posts
if it's excessive pressure from engine compression/combustion maybe removing the oil cap would help you determine that, if it then doesn't leak with the cap off then you are getting excess pressure in the crankcase.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I never had any water pump issues or did it ever overheat, I tried taking the oil fill cap off and it still leaks oil out of the weep hole.

All the seals are new and they are all facing the right direction, and they're all Kawasaki seals.

I'm almost at the point where I just take it in.
Out of over 30 bikes I have owned, I never had one in the shop. I'm glad I have a honda 919 to ride, because this z is a major headache
 

·
Registered
Joined
·
1,175 Posts
Tim, you did the work on this, right?

Theres no way you do it incorrectly, three times.....Maybe once but that would have been corrected on the 2nd or 3rd try.

What supports the shaft, itself? I picture your new seals being ok, obviously, but if something is letting the shaft move around, excessively, then it immediately tears up your new seals and lets them leak?
 

·
Registered
Joined
·
95 Posts
Tim, you did the work on this, right?

Theres no way you do it incorrectly, three times.....Maybe once but that would have been corrected on the 2nd or 3rd try.

What supports the shaft, itself? I picture your new seals being ok, obviously, but if something is letting the shaft move around, excessively, then it immediately tears up your new seals and lets them leak?


Tim any luck with your oil leak issue?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1 Posts
Hey guys I have the same problem with my 2003 Z1000. My bike has been sitting for he past 2 months at a bike shop that I do business with since a long time. In my case the oil spills out at high rev. All the part and test your thread suggested was done. The only thing left to do is the release valve. It test OK but we purchased a new one and this is the last ressource we have. I was wondering what happened with your case. Did you fix your problem and if yes what was the fix. Thank you replying promptly.
 

·
Registered
Joined
·
2 Posts
Does anyone have a diagram or photo showing the oil seal and spring behind the impeller that shows the order and directions of the seals? I have my 05 apart and for the life of me can’t make sense of the spring/oil seal. I can’t find the spring in the manual or any parts diagrams.
 
1 - 13 of 13 Posts
Top