Kawasaki Z1000 Forum banner

21 - 26 of 26 Posts

·
Registered
Joined
·
16 Posts
Ok so Ive since taken possesion of my gen 2 Z and had a look at the headlights,, it is a strange arrangement; ok the h7 drops in as normal, but then there is a 10mm thick spacer that plugs in to the h7 bulb, converts it to the h4 plug type that is on the loom for no apparent reason, provides the 10mm spacing the retaining spring needs for no apparent reason, and provides the "neck" for want of a better word that seals the rubber.
Very strange. Its like the design team changed their mind several times as to what bulb they were going to use during the production of the bike.
So long story short, cheap stupid LED bulbs with no ballast or heatsink will drop straight in, but anything that will be anywhere near useful will require some McGyvering, in the form of at least a home made spacer.
 

·
Registered
Joined
·
1,150 Posts
That's what I found on my Gen3. It's easiest to just leave them as they are.


I'm halfway through a projector retrofit, because my projectors are too deep for my stock housing, but it's really the way to go if you'd like to see an improvement.


Here are some references:


https://www.z1000forum.com/forum/z1000-appearance-modifications/140329-headlight-retrofit-opening-modifications.html


https://www.z1000forum.com/forum/z1000-appearance-modifications/155457-another-headlight-retrofit.html


https://www.z1000forum.com/forum/off-topic-discussion/148209-retrofit-month-contest-winner.html
 

·
Registered
Joined
·
2 Posts
Just made the same discovery as Kermit, its got me wondering if an H4 LED bulb will fit fine if we just bypass the adaptor?

I installed my new LED H7's into my 3rd gen Z, but the High Beam switch doesn't activate anything. I swapped connectors to make sure it wasnt a dud bulb and sure enough it was fine. Neither side wanted to be the High beam...cant figure out why. Either way the running light works fine and looks great!
 

·
Registered
Joined
·
1,150 Posts
Just made the same discovery as Kermit, its got me wondering if an H4 LED bulb will fit fine if we just bypass the adaptor?

I installed my new LED H7's into my 3rd gen Z, but the High Beam switch doesn't activate anything. I swapped connectors to make sure it wasnt a dud bulb and sure enough it was fine. Neither side wanted to be the High beam...cant figure out why. Either way the running light works fine and looks great!

That's a double-no. Put projectors in it, or some Philips H7s.
 
21 - 26 of 26 Posts
Top