Kawasaki Z1000 Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
im gonna post in the trouble shooting section. but i own a cbr and z1000 and so far this 1000 is junk! it only runs for about 15 minutes and then quits, it'll stall out, and it will be nearly impossible to start again you have to wait and even then it wont go above 10 mph. its a 2003 with a pc3 and full muzzy exhaust. other then that i know nothing about it.
 

·
Registered
Joined
·
2,318 Posts
im gonna post in the trouble shooting section. but i own a cbr and z1000 and so far this 1000 is junk! it only runs for about 15 minutes and then quits, it'll stall out, and it will be nearly impossible to start again you have to wait and even then it wont go above 10 mph. its a 2003 with a pc3 and full muzzy exhaust. other then that i know nothing about it.
Take the PC3 off, and try it. I have heard of those going bad, after awhile.... If it runs longer than your 15 mins you need to replace the PC3. 2003 is the best year man! I have done nothing but change oil and tires for mine minus the set of sprox and chain I put on this year.... and mine has almost 30k on it. Its my 2nd '03, RIP my first love.....:D
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
I'll give it a try. I dunno how the pc3 goes on there, but im sure its pretty similar to my cbr. do I have to disconnect it all the way from the injectors or can i just unplug the negative from it? thank you in advance!
 

·
Registered
Joined
·
2,318 Posts
I believe under the tank it plugs into the main harness, not individual injectors. So unhooking it there is what I would do, and then plug the two ends of the main harness back together, and you should be running off the stock ECU fuel map then. I am not sure about the mechanics of the PC3, but maybe someone else could tell you if you could just unhook it from the battery to bypass it for now.

Side note: Only run it without PC3 to test it out. Since you are running a full system there is a chance that running the stock map could cause you to be running on the lean side. Get some other kind of fuel management before you start riding it regularly.....nobody likes a melted piston!
 

·
Registered
Joined
·
752 Posts
im gonna post in the trouble shooting section. but i own a cbr and z1000 and so far this 1000 is junk! it only runs for about 15 minutes and then quits, it'll stall out, and it will be nearly impossible to start again you have to wait and even then it wont go above 10 mph. its a 2003 with a pc3 and full muzzy exhaust. other then that i know nothing about it.
Man, for a second there, I thought you were a troll Honda fan boy...this post sounded like Sony fan boys who sneak onto Xbox 360 forums and post things saying "Waaaa...my xbox is a piece of crap! Why does it have the red ring of death?" Funny thing is, they were doing this to occupy themselves while the Sony Online system was on meltdown due to HACKERS.

Sorry - completely off topic. But the post reminded me of that...
 

·
Registered
Joined
·
752 Posts
Probably not the best idea to come onto a forum dedicated to the Z1000 and call it "junk."

Ever heard how you can catch more flies with honey? Might try that next time.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #9 ·
Well after buying it from a dealer, and it never working only being able to ride 20 minutes, I can only assume junk. However, troll I am not. Honda fan I am.

Back on topic, thank you for the suggestions on removing the PC. Because it worked. Thank you. Side note, removing the negative feed wont work, have to remove whole thing.

To the riding portion, i had fun on it, i really like it. Not junk, I retract that. Thanks guys.
 

·
Registered
Joined
·
752 Posts
Well after buying it from a dealer, and it never working only being able to ride 20 minutes, I can only assume junk. However, troll I am not. Honda fan I am.

Back on topic, thank you for the suggestions on removing the PC. Because it worked. Thank you. Side note, removing the negative feed wont work, have to remove whole thing.

To the riding portion, i had fun on it, i really like it. Not junk, I retract that. Thanks guys.
In that case, you should bad mouth the dealer who sold you the bike - not the bike itself!!!

Glad to hear you got it fixed. Now - dont go riding it until you replace the PC3!! Either that or you are running it really lean, and could hole a piston! Then you'll be griping about your bike being a POS again :lol:

Suggestion: call wrecking yards and see if they have any. Get one for CHEAP!

Good luck, bro.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #11 ·
Dont worry I bad mouthed him as well, he was the first one. Gooch Powersports in henderson, tn. Bad everything. Anyway yeah I plan on it thanks
 

·
Registered
Joined
·
2,318 Posts
Whaddya know, sometimes I do know what I am talking about!? LMFAO!!! I was hoping it was going to be that easy for you, glad it worked out.
 

·
Registered
Joined
·
59 Posts
Yeah as is so no warrenty
If the Bill of Sale did not say sold AS IS im pretty sure they still have a responsibility to help you out.

Even without a warrenty its just bad business to sell a crap bike and not at least give you a discount on repairs........

If I get in situations like that with "unethical *ss hole people" who are not willing to fix an issue with a paying customer I always threaten to call the Better Business Bureal and the local news stations.

While what they did may not be illegal its bad practice and news stations go ape shi$ for that.....

They may change there mind
 
1 - 18 of 18 Posts
Top