Kawasaki Z1000 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
recently bought a 2007 Z1000 . new to biking world

it had a problem of engine shutting down smtimes on first gear ppick up from throttle zero.

things have got severe in last two days. engines just shutts down in on throttle is zero even while changing gears. got into trouble in running traffic due to this

any one with such experience?

climate here is very dusty/ sandy as bahrain is a dessert. can this be reason or bad fuel quality or air cleaner ?

Kawi agent says its clogged injectors but i am not sure how the injectors are clogged in two days and earlier they were not that severe.

any suggestions?
 

·
Registered
Joined
·
249 Posts
I agree with the Kawasaki agent on this one. What you're describing sounds like clogged injectors. They may not have been as bad two days earlier, but it still sounds like they were clogged up. That's the kind of behavior my bike exhibited with it's carburetors when they got clogged.

I can't speak to desert riding with any authority, though.
 

·
Registered
Joined
·
11 Posts
recently bought a 2007 Z1000 . new to biking world

It had a problem of engine shutting down smtimes on first gear ppick up from throttle zero.

things have got severe in last two days. engines just shutts down in on throttle is zero even while changing gears. got into trouble in running traffic due to this

any one with such experience?

climate here is very dusty/ sandy as bahrain is a dessert. can this be reason or bad fuel quality or air cleaner ?

Kawi agent says its clogged injectors but i am not sure how the injectors are clogged in two days and earlier they were not that severe.

any suggestions?
Are you able to start the bike? If your, able run some fuel injector cleaner, and see if that helps, also what octane are you using? runs best on plus or premium. Also is the same problem consistent with a full fuel tank or or below half? If so, check your hose's and check inside your fuel tank to see if any gunk is floating, or sitting at the bottom of your tank.

Good luck, regards, canonfuji.
 

·
Registered
Joined
·
4 Posts
i have a 2007 also with about 13000 mile on it. do you have issues with when you turn on the key sometimes the fuel pump runs and sometimes it doesn't? i am currently going through this issue with mine as well as the bike dying when the throttle is released. i turned my bike into a dealer for troubleshooting and the best they could come up with right now is that the ECU is bad. seeing as how the cheapest i can find one is $650, it's gonna be tough to let you know if that is what fixes the problem. the dealer said that a generic code was given and there is no way to test the ECU itself on our model. i hope this helps a little and good luck figuring out your issue if this is not the same thing.
 

·
Registered
Joined
·
4 Posts
also, when your bike dies, do all the guage lights light up to include both turn signal indicators? that was another wierd thing to happen to mine.
 
1 - 5 of 5 Posts
Top