Kawasaki Z1000 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Throttle will not go past 1/4 turn on occasion, or it will get stuck wide open. I just bought and replaced throttle cables as well as re-routed them just to make sure they weren't getting pinched or caught. It will only do it while the bike is turned on and rolling down the road. Have called local Kawi dealer to be told they have no clue, as well as got a few mechanics' opinions on the issue. Anyone have any ideas? I'm convinced it may be TPS :crying:
 

·
Registered
Joined
·
408 Posts
Well that is scary as hell. I would not want my bike sticking at WOT! If the cables are good and routed correctly. Maybe the butterfly in the throttle body? If it's a mechanical sticking has to be something physically sticking. Tps couldn't do that. If you are letting off throttle and the cable returns but the bike keeps pulling idk that's really weird. Maybe big vacuum leak but it would run like crap.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3 (Edited)
I've found the issue. It's ECU. Went looking through the bike last night and it has some cheap chinese ecu installed and factory gone, Going to just order bazzaz z-fi to replace factory ecu since it's 300 dollars as compared to 950 for factory.

EDIT: I'm dumb, just gonna have to buy factory ecu
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Well that is scary as hell. I would not want my bike sticking at WOT! If the cables are good and routed correctly. Maybe the butterfly in the throttle body? If it's a mechanical sticking has to be something physically sticking. Tps couldn't do that. If you are letting off throttle and the cable returns but the bike keeps pulling idk that's really weird. Maybe big vacuum leak but it would run like crap.
The thing is, it only does it while the bike is running. Cables won't snap back unless I take a wrench and force them to do it myself. Seems electrical since it only does it while the bike is running and going down the road.
 

·
Super Moderator
Joined
·
3,069 Posts
If the throttle wont snap closed when you release it, it's a throttle body, throttle tube, or throttle cable issue.

The ECU wont hold the throttle open.
 

·
Registered
Joined
·
207 Posts
while lifting the gas tank for spark plug change, one of the two little hard rubber thingies glued to the frame came off. After the plug change I didn't notice it gone. What I did notice was the throttle sticking while driving. The thingy dropped right behind the throttle linkage and would intermittently stick it!!
 

·
Super Moderator
Joined
·
3,069 Posts
Ha I would have never thought of that happening. Glad it didn't cause a wreck or any major damage.

OP probably has a simple problem like this and just hasn't noticed it.
 

·
Registered
Joined
·
1,071 Posts
This sounds like an optional accessory......

Lets start a company based around it and say this is an "occasional cruise control". Maybe charge 399.00? Buy 2 get one free?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
Took a while to figure out, maybe its a 2011z problem lol. Thank goodness the kill switch worked !
So it's been quite a few months but on the way home from work, it happened again. Gonna look into what you said this weekend, sorta scared to ride it to work!
 
1 - 10 of 10 Posts
Top