Kawasaki Z1000 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I know it's another post about cutting our. I've searched the forum and nothing is quite like my issue so I thought I'd post and see if I could get some help. The bike has 34k on it and it has been cutting out after riding a while. When it cuts out the speedometer resets like I'm turning the key off and back on. This is getting worse and I've noticed if I don't bring the rpms up past about 6k it is fine. Anyone got any ideas? Thanks in advance
 

·
Registered
Joined
·
31 Posts
I know it's another post about cutting our. I've searched the forum and nothing is quite like my issue so I thought I'd post and see if I could get some help. The bike has 34k on it and it has been cutting out after riding a while. When it cuts out the speedometer resets like I'm turning the key off and back on. This is getting worse and I've noticed if I don't bring the rpms up past about 6k it is fine. Anyone got any ideas? Thanks in advance
have u cleaned your fuel tank make sure no rust and then filter mine had a bog issue after i rode for about 20 min then i kill switch then turn it back on while holding clutch then its good but i got a new tank and ever since then haven't had much of a issue have u checked your wires for any bends or the power going through or lack of.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Also I just changed the plugs and removed a power commander 3 USB and an ignition module as well thinking it may have been the issue. It seemed like it was better for a day or two but now it's worse than before. Seems like the bike is cutting power to everything and now when it does it it won't right itself without turning the key off and back on
 
1 - 6 of 6 Posts
Top