Kawasaki Z1000 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey all, my water pump/ oil cooler has started leaking oil and its dripping down onto the exhaust. I took it to a shop and they quoted my $570 for the part or they could try to rebuild it for cheaper and it would last for a while. I chose the rebuild path and it worked for a couple thousand miles but now the seals have failed again. I took it upon myself to do some independent research about the part and I can't find it anywhere online and the couple dealerships I've called quoted me the same price. Is there anywhere else I could find one of these water pumps? Are there ever any used water pumps that pop up? Thank you so much for all your help guys!
 

·
Registered
Joined
·
113 Posts
What is an water pump / oil cooler ?



You say it's leaking oil ?

.. and it's coming out from the water pump cover ?

or is it leaking from where the oil filter mounts ?


I have a problem with the diagnose' something about this just doesn't sound right, I guess that's why it's a problem
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Hey all, I'm sorry I wasn't able to get back to you guys for so long! So I figured out where it was leaking from, If you see on my second picture the small hole at the bottom of the body of the oil pump, of number 16160 of the diagram! Now my only question is what goes in there? If I can't find an answer within a couple of days I'm going to take it to a metal fab shop and have them weld the hole closed because with the previous body, the previous owner must've saw it leaking and he stuck a wood screw in there to stop it. I just thought he messed up the threads and I tried to tap new ones with no luck so I just ordered a new body. Well this new body doesn't have any threads on that hole and I've been scouring the internet to try and find out what is supposed to go there. I don't know if its supposed to be a return line of some sort or what but like I said if I can't find an answer im just going to get the hole welded shut
 

Attachments

·
Registered
Joined
·
1,150 Posts
$5 says it's a weep hole. There's nothing connected to it in the parts diagram. I suspect if you have it sealed that coolant will come out somewhere else.


Open up your Service manual to page 4-10:












It looks like you need new seals again. :-(


If it happens agin after this replacement, I'd maybe consider ignoring the instructions and applying a very, very small amount of gasket maker to the seal.


Good luck!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
Alright! I got everything bolted back up now I just need to fill the coolant, from the manual I have to remove the tank for that correct? Also I'm now getting a low oil pressure light which I'm a little confused I can't seem to figure out :(
 

·
Registered
Joined
·
1,150 Posts
You should not start the bike without coolant or oil.


You'll have to look in your manual, but I had a low pressure light once, and solved it by running the bike for a minute with the oil filter loosened until oil came out the seal, then tightened it up again.
 

·
Registered
Joined
·
113 Posts
Are you filling up the oil filter before before inserting onto the bike ?
You should be, fill and let soak into the filter than refill it before putting the oil filter on. not 100% full but close to 90%.
 
1 - 12 of 12 Posts
Top