2003 FI light followed by dash loss - Kawasaki Z1000 Forum: Kawasaki Z1000 Motorcycle Forums
User Tag List

 1Likes
  • 1 Post By MyOrangeZ
 
LinkBack Thread Tools
post #1 of 3 Old 06-01-2019, 12:41 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2003 FI light followed by dash loss

I have a 2003 Z1000 having issues I can’t figure out. After a rain storm last night, I was hoping to go out on a ride today. As I drove to the gas station, I realized the FI light was on. I returned home to check for codes. In dealer mode 1, I got a 52 code which is coil #2 . Since the bike had been out in the rain and other than the light being on, it was running fine, I figured I could go ride and hopefully any moisture would dry out. As I was leaving the driveway, my bike shut off and I lost all display on my instrument cluster. When I turn the key, you can hear the fuel pump prime, but nothing else happens. Any ideas would be greatly appreciated.
MyOrangeZ is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-09-2019, 01:46 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
After digging into it, found the ignition fuse blown. Decided to pull the #2 coil to shoot the wires and found the coil completely melted through. After replacing the coil, she’s back on the road.
Attached Images
File Type: jpg C3D466B3-8032-41BB-BC30-602B6A8A5AD1_1560102333559.jpg (97.1 KB, 4 views)
File Type: jpg 6D6734C3-6209-45C4-AC90-735B36A52DB7_1560102359723.jpg (75.2 KB, 3 views)
File Type: jpg 63E21497-01F1-4328-BB60-9308A0781CCC_1560102377819.jpg (104.7 KB, 4 views)
JohnJuan likes this.
MyOrangeZ is offline  
post #3 of 3 Old 06-10-2019, 10:14 AM
Senior Member
 
JohnJuan's Avatar
 
Join Date: Dec 2012
Location: Minneapolis
Posts: 1,030
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 84 Post(s)
Garage
Nice work. That coil got pretty messed up.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JohnJuan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Z1000 Forum: Kawasaki Z1000 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome