after new spark plugs/air filter engine light is on! - Kawasaki Z1000 Forum: Kawasaki Z1000 Motorcycle Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 6 Old 04-02-2019, 08:01 PM Thread Starter
Member
 
Join Date: Oct 2018
Posts: 30
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Question after new spark plugs/air filter engine light is on!

Hi guys,

2017 model. Before putting back airbox, i started the engine but only for a sec. Now after half way putting back fairings, i decided to try the engine. Starts and runs fine. very smooth as always. But engine light is on. Any idea what I have done wrong?

your help is appreciated.
thisisme is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-03-2019, 10:18 PM
Junior Member
 
Join Date: May 2017
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Lift the tank up again and make sure no hoses are crimped underneath and all hoses are re-attached to airbox


Sent from my iPhone using Tapatalk
2E1gixxer is offline  
post #3 of 6 Old 04-04-2019, 09:23 AM Thread Starter
Member
 
Join Date: Oct 2018
Posts: 30
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Quote:
Originally Posted by 2E1gixxer View Post
Lift the tank up again and make sure no hoses are crimped underneath and all hoses are re-attached to airbox


Sent from my iPhone using Tapatalk
I did. There were 3. Two bigger hoses and one small (drain or something). Also one electronic sensor wire. All connected.

I was thinking if that sensor is disconnected and start the engine (what I did when airbox was out), definitely it will cause engine light to go off. So question is, when reconnecting the sensor (now) does the created "Diagnostic trouble code" gets deleted automatically and engine light turns back to normal?!
thisisme is offline  
 
post #4 of 6 Old 04-04-2019, 07:00 PM Thread Starter
Member
 
Join Date: Oct 2018
Posts: 30
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Guys, Here is what I've learned. Service code is 13. Holding top button on dash for 2+ sec (when ignition is on) will display the code.

code means: Intake air temperature sensor malfunction, wiring open or short

So my guess was right. I let the engine run for few seconds when airbox was out.

Now question is, how can I turn it off?! Service manual says:

○When repair has been done, yellow engine warning indicator (LED) or red warning indicator (LED)
and immobilizer warning indicator go off and service code is not displayed.

The service codes stored in memory of the ECU can be erased using Kawasaki Diagnostic System
(KDS Ver.3).

I have been riding it for some time and engine light is still on. So I guess should take it to dealership :-(
thisisme is offline  
post #5 of 6 Old 04-06-2019, 02:38 PM Thread Starter
Member
 
Join Date: Oct 2018
Posts: 30
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Update:

After riding it more, FI code cleared automatically and engine light is off now.

FYI, just in case someone else face such problem.
thisisme is offline  
post #6 of 6 Old 04-08-2019, 08:25 PM
Junior Member
 
Join Date: May 2017
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Quote:
Originally Posted by thisisme View Post
Update:



After riding it more, FI code cleared automatically and engine light is off now.



FYI, just in case someone else face such problem.


Good info and worth noting!


Sent from my iPhone using Tapatalk
2E1gixxer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Z1000 Forum: Kawasaki Z1000 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome