Transmission Rattle noise at start up -FIX - Page 8 - Kawasaki Z1000 Forum: Kawasaki Z1000 Motorcycle Forums
User Tag List

 2Likes
Reply
 
LinkBack Thread Tools
post #71 of 71 Old 04-27-2019, 08:20 PM
Member
 
Bandicoot92's Avatar
 
Join Date: Jun 2018
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Garage
Quote:
Originally Posted by nate1235 View Post
Clutch operates just fine. I'm just annoyed by the noise and worried about the longevity of the clutch with oil starvation. I'll let you know how it improves the noise.
Hello my friend , I know it's an old post but I would appreciate some informations cause I m sick of that clunking sound when I shift up or down . You said your annoyed by the noise , which noice ? And what about the oil , was it ok ? Does this mod worth it ? Cause I can't figure out from these comments if it worth doing it. Also I saw the videos of the mod and that guy didn't grind down the pin , how do I know if my pin needs to be grind down. I sorry for bothering you .
Bandicoot92 is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Z1000 Forum: Kawasaki Z1000 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome