Exhaust mod - Kawasaki Z1000 Forum: Kawasaki Z1000 Motorcycle Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 2 Old 05-14-2019, 10:37 AM Thread Starter
Junior Member
 
Leesz1000r's Avatar
 
Join Date: May 2019
Location: Newport, South Wales, uk
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Exhaust mod

need advice..... I've got a 2017 z1000r,with Austin racing cans,with delkavic headers,I haven't got the money yet for a while for an ECU flash. A)do I need to fit a k&n air filter and B)will I do any damage to my bike runing it as is,I've taken the baffle out,would it benefit me to run it with baffles in.... I appreciate any advice given... Thank u...
Leesz1000r is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-16-2019, 04:50 AM
Junior Member
 
Join Date: Mar 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Well, if you dont add the filter you should be fine for a while but you really should get the ECU reflash
The bike will not brake, have i friend that drives HARD with arrow headers and cans and he have no problem.
Erajk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Z1000 Forum: Kawasaki Z1000 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome