Amateur mistake - Kawasaki Z1000 Forum: Kawasaki Z1000 Motorcycle Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 4 Old 11-25-2019, 12:48 PM Thread Starter
Junior Member
 
Join Date: Nov 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Name says it all .. Went out and bought 07 z1000 and managed to hook up battery connectors wrong , pulled them off immediately. Well In the beginning It was dead , completely. Bought a new battery and after combing through the fuse boxes under the seats I managed to find a blue fuse w the print “ 30 “ on it I believe, that was blown and I replaced it . Well now every 1 in 15 tries or so itll turn on and the screen and everything will come on and it actually fired all the way up once but then turned off again .. Any help at all is appreciated!

Last edited by Beginnerbiker; 11-25-2019 at 12:51 PM.
Beginnerbiker is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-25-2019, 02:46 PM
Senior Member
 
JohnJuan's Avatar
 
Join Date: Dec 2012
Location: Minneapolis
Posts: 1,104
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 109 Post(s)
Garage
I don't know, but we do have the service manuals here:


https://www.z1000forum.com/forum/z10...al-hosted.html


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JohnJuan is offline  
post #3 of 4 Old 11-26-2019, 02:43 PM
Member
 
Join Date: Jul 2015
Location: united kingdom
Posts: 71
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
proberbly blown the Rectifyer/regulator, get it checked out first..
Trebor4460 is offline  
 
post #4 of 4 Old 11-29-2019, 11:06 AM Thread Starter
Junior Member
 
Join Date: Nov 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Can I check that myself ? Or do I need to take it to the shop ?
Beginnerbiker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Z1000 Forum: Kawasaki Z1000 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome